Por qué no funciona Tag Manager o la vista previa si parece bien instalado

Posted by Lucía Marín on Ene 12, 2020

A veces ocurren cosas extrañas en una instalación de Tag Manager y también en los primeros pasos con la herramienta.
Nos encontramos con que todo parece correcto, el código está en la web y debería funcionar todo bien. Sin embargo, o bien no aparece nada en Tag Assistant, o aparece con error. O la problemática es con la vista previa, que no salta.
Voy a mezclar en este post todo este popurrí de posibles fallos de lo más sencillo a lo más avanzado, esperando que os resulte útil y os salve de horas o días de atasco… que alguna vez a mí ya me los ha costado, ¿para qué dedicarle más tiempo inutilmente si otros ya nos hemos tropezado ahí?

ESCENARIO
He instalado GTM pero no funciona algo, o no reporta datos, o no se ve la vista previa, algo huele…
¿qué puede estar pasando?
Pasos para verificar y corregir:

1. Verificar que el código está instalado bien y sigue ahí, empezar siempre por lo más elemental… A veces, hasta resulta que hemos estado recibiendo datos en GA o en Ads, y de pronto se dejan de recibir a partir de una fecha. ¿Qué puede haber pasado? pues lo más fácil suele ser la respuesta: que alguien haya quitado el código por error, que la última actualización automática de la plantilla de WordPress u otro CMS se haya llevado nuestras personalizaciones, que otros proveedores de nuestro cliente hayan machacado una versión de archivo con el código por otra sin él…

2. Asegurarnos de que el plugin Gosthery no está activo si queremos tener vista previa disponible. En muchas ocasiones, al tener dicho plugin instalado, deja de funcionar la vista previa de Tag Manager.

3. Rareza en WordPress: imaginad que tenemos el código instalado a mano o con plugin pero no reporta datos ni tan siquiera sale en Tag Assistant. En alguna ocasión me ha ocurrido, y tras verificar que el código estaba en página, me di cuenta de que se había minificado el todo código HTML. ¿Y qué ocurrió? que al quitar saltos de línea, como WordPress inserta comentarios CDATA en el script de GTM, se comenta todo el JavaScript y por supuesto Tag Manager deja de funcionar en la página…

4. Si no encontramos ninguna causa clara en instalación de GTM y parece que el código está ahí, comprobar que no haya exceso de errores JS en la página, que las comillas del código JS no se hayan torcido, etc. etc.

Ojalá os ahorre un disgusto!! yo me lo quedo de recopilatorio para siguientes ocasiones :)
Y feliz año nuevo 2020 por cierto!!!!

Sobre mí

5 Comments

  • Rebeca says:

    Hola, Lucía. Tengo un formulario que se despliega al hacer clic en un botón. Estoy intentando configurar el evento en Tag Manager y he probado todos los métodos: con ID de formulario, con visibilidad de elemento copiando el Selector CSS del mensaje de «envío correcto» que aparece en la página, con un evento simple de envío de formulario. Nada. El problema es que de ninguna manera se activa el trigger. Sólo se ha activado con Visibilidad de elemento, pero lo hace en cuanto despliego el formulario, no cuando aparece el mensaje de confirmación (que sería lo correcto). Sin embargo recibo los formularios en mi correo. Espero que puedas ayudarme. Gracias.

  • 01:59
    20 Nov 20
    administrator

    Lucía Marín says:

    Hola Rebeca, sin saber más, huele a que el selector CSS o ID que has puesto en el trigger de visibilidad es el del formulario, no el del mensaje de gracias… podría ser?

  • luxo87 says:

    Hola Lucía,

    Soy nuevo en esto y no logro que funcione, no entiendo que es lo que hago mal.

    1. Hago toda la instalación y en la extensión de tag assistant me aparece: analytics (en azul) y el tag manager dos veces en color verde.

    2. No me carga la parte del cuadro de abajo, que me canse de ver vídeos y veo que siempre sale.

    Muchas gracias por la ayuda

  • 01:46
    25 Ene 21
    administrator

    Lucía Marín says:

    Hola, gracias por comentar, dices la vista previa? ha cambiado y ya no sale abajo, mira este otro post mío sobre los cambios en la vista previa. Espero que te ayude :) ahí encontrarás también otros posts que a mí me han ayudando a entenderla.

  • Rafael Saldaña says:

    Hola Lucía, tengo una agencia y siempre instalo etiquetas de Google Tag Manager sin problemas, pero ahora me ha pasado algo raro, mi cliente instaló la etiqueta de mi Google Tag Manager para yo poder instalar el resto como: pixel, metricool, GA4, conversiones de Google Ads, etc. Pero el problema es que cuando le doy a Vista previa, me aparece el google analytics de mi cliente (el cual él me ha compartido) y no aparecen las etiquetas. Obvio el pixel no funciona, no recibe datos.

Comments are closed.